Vulnerable Drupal Modules

Recently, three Drupal v7.x modules have been found to be affected by a remote code execution vulnerability, calling attention from Drupal Developers and site owners worldwide. Let us find out about the nature of the vulnerability, its effect, and the solutions thereof.

What is the Remote Code Execution Vulnerability?

According to Wikipedia, “arbitrary code execution vulnerability is used to describe a software bug that gives an attacker a way to execute arbitrary code.” Furthermore, Wikipedia refers to remote code execution as the ability to trigger arbitrary code execution from one machine to another via a wide-area network such as the internet.

Thus, remote code execution vulnerability refers to a software bug that gives attacker the ability to trigger arbitrary code execution from one machine to another.

Let us, now delve deeper into the details about the affected modules and the proposed solutions:

RESTful Web Services Module

USE: The module is used to create REST APIs
VERSIONS AFFECTED:7.x-2.x versions prior to 7.x-2.6 and 7.x-1.x versions prior to 7.x-1.7
SITES AFFECTED: 5800
SECURITY RISK:Highly Critical (ie interaction with the website is not required to exploit the vulnerability)
MITIGATING FACTOR:No mitigating factor is present
SOLUTION:Upgrade to the latest version (ie RESTful Web Services v7.x- 2.6 or v7.x-1.7)

Coder Module

USE:The module checks the site’s code against coding standards and fixes coding errors. Additionally, it also executes basic upgrades on a site’s modules.
VERSIONS AFFECTED:7.x-1.x versions prior to v7.x-1.3 and 7.x-2.x versions prior to v7.x- 2.6
SITES AFFECTED: 4950
SECURITY RISK: Highly Critical
MITIGATING FACTOR: No mitigating factor is present
SOLUTION: Remove the module from public websites or update to the latest version of the module.(ie Coder v7.x-1.3 or Coder v7.x-2.6)

Web Form Multiple File Upload

USE: The module lets users upload multiple files on a web form
VERSIONS AFFECTED: 7.x-1.x versions prior to v7.x-1.4
SITES AFFECTED: 3000
SECURITY RISK: Critical (ie interaction with a website in some way is required to exploit the vulnerability and cause major damage)
MITIGATING FACTOR: The attacker must be able to submit a Webform with a multiple file input field.
SOLUTION:Upgrade module to the latest version. (ie version 7.x-1.4)

If you have an affected module version on your Drupal Website, make sure you employ the suggested solutions and protect your site from unwanted attacks.